Configuración de Cisco Call Manager Express en Routers Cisco


En este post explicare respecto a los pasos a seguir para configurar el servicio de telefonía básico de Cisco utilizando el CME (Cal Manager Express), para el cual utilizaremos un router Modelo 3725 con la imagen IOS c3725-adventerprisek9-mz.124-15.T7.

Adicionalmente las herramientas para un laboratorio home made se detallan a continuación:

    1. GNS
    2. Servidor TFTP
    3. Cisco IP Communicator (Softphone)
    4. Sanboxie
    5. Archivos CME

La topología para el laboratorio se resume en la siguiente imagen:

image

Paso 1: Configurar el Router con los parámetros de Red que se detallan en el diagrama de topología

CME-ZONE1(config)# interface FastEthernet 0/0
CME-ZONE1(config-if)# description LINK to LAN1
CME-ZONE1(config-if)# ip address 172.16.1.1 255.255.255.0
CME-ZONE1(config-if)# no shutdown

Habilitar el servicio de DHCP con la opción 150 para poder habilitar el servicio de TFTP para que los teléfonos IP adquieran tanto la dirección de manera dinámica como los archivos de imagen de firmware y de configuración mediante el servicio TFTP

CME-ZONE1(config)#ip dhcp pool VOICE1
CME-ZONE1(dhcp-config)#network 172.16.1.0 255.255.255.0
CME-ZONE1(dhcp-config)#default-router 172.16.1.1
CME-ZONE1(dhcp-config)#domain-name zone1.com
CME-ZONE1(dhcp-config)#option 150 ip 172.16.1.1

Paso 2: Cargar mediante TFTP el contenedor que almacena todos archivos requeridos para que un router pueda brindar el servicio de telefonía mediante el CME, para ello haremos uso del programa TFTP que se detalla al inicio de este post.

Primero cargaremos el programa y luego seleccionamos la interfaz del pc local que estaría corriendo la instancia del servidor TFTP, adicionalmente deberemos de seleccionar la ruta donde se encuentra almacenado el archivo que contiene el instalador del CME con la extensión .TAR

Para nuestro ejemplo, la IP local donde estamos corriendo el servicio es la 172.16.1.2 y el directorio donde se encuentra el instalador del CME es C:\Program Files\Tftpd32

image

 

Luego, desde el router ejecutamos el siguiente comando para cargar el instalador, lo almacenaremos en la memoria FLASH y al mismo tiempo ejecutaremos el comando ARCHIVE para que genere los directorios que contiene el archivo .TAR

CME-ZONE1#archive tar /xtract tftp://172.16.1.2/cme-full-4.3.0.0.tar flash:

Luego de ejecutar el comando, observamos que el servidor habilitado en la red local comienza a enviar el archivo que le indcamos al router.

image

Al mismo tiempo podemos observar en el router que se comienzan a crear los directorios que contienen todos los archivos que son requeridos para poner en marcha el servicio de telefonía

image

Paso 3: Finalizado el proceso de carga de todos los archivos requeridos podemos comenzar a configurar el servicio de telefonía en el router

Primero deberemos de indicarle al router los archivos que deberá utilizar para configurar los teléfonos IP, para nuestro ejemplo utilizaremos los archivos del modelo 7970-7971

CME-ZONE1(config)#tftp-server flash:/phone/7970-7971/apps70.8-3-2-27.sbn alias apps70.8-3-2-27.sbn
CME-ZONE1(config)#tftp-server flash:/phone/7970-7971/cnu70.8-3-2-27.sbn alias cnu70.8-3-2-27.sbn
CME-ZONE1(config)#tftp-server flash:/phone/7970-7971/cvm70sccp.8-3-2-27.sbn alias cvm70sccp.8-3-2-27.sbn
CME-ZONE1(config)#tftp-server flash:/phone/7970-7971/dsp70.8-3-2-27.sbn alias dsp70.8-3-2-27.sbn
CME-ZONE1(config)#tftp-server flash:/phone/7970-7971/jar70sccp.8-3-2-27.sbn alias jar70sccp.8-3-2-27.sbn
CME-ZONE1(config)#tftp-server flash:/phone/7970-7971/SCCP70.8-3-3S.loads alias SCCP70.8-3-3S.loads
CME-ZONE1(config)#tftp-server flash:/phone/7970-7971/term70.default.loads alias term70.default.loads
CME-ZONE1(config)#tftp-server flash:/phone/7970-7971/term71.default.loads alias term71.default.loads

Luego habilitamos el servicio de telefonía con los siguientes comandos:

CME-ZONE1(config)#telephony-service
Habilitamos el servicio de telefonía

CME-ZONE1(config-telephony)# max-ephones 6
Definimos un máximo de 6 teléfonos IP, este comando es importante considerarlo en base a las limitaciones de hardware del router que estemos utilizando, dependiendo de la cantidad de memoria RAM disponible así será el máximo de teléfonos que el sistema permita habilitar

CME-ZONE1(config-telephony)# max-dn 10
Definimos la cantidad de extensiones que tendremos disponibles para asignarle a los teléfonos IP

CME-ZONE1(config-telephony)# ip source-address 172.16.1.1 port 2000
Configuramos la IP del router que brindara el servicio de telefonía y el puerto que será el que CISCO indica por defecto

CME-ZONE1(config-telephony)# system message Tecnosystem ZONE 1
Detallamos el nombre que tendrá nuestra red de telefonía, este nombre es el que nos permitirá identificar en los teléfonos a que servicio de telefonía estamos asociados.

CME-ZONE1(config-telephony)# time-zone 8
Configuramos la zona horaria que tendrán los teléfonos

CME-ZONE1(config-telephony)#web admin system name cisco secret  cisco
Detallamos las credenciales de acceso que se utilizaran en caso deseemos realizar configuraciones adicionales mediante el GUI que el CME tiene disponible, en caso no deseemos utilizar la CLI para configurar extensiones adicionales

CME-ZONE1(config-telephony)# dn-webedit
Habilitamos la opción de poder utilizar el GUI del CME

CME-ZONE1(config-telephony)#create cnf-files
Finalmente creamos el archivo de configuración que se entregara a todos los teléfonos que se registren con el CME configurado en este router.

Para habilitar el servicio de configuración desde el GUI del CME ingresamos los comandos:

CME-ZONE1(config)#ip http server
CME-ZONE1(config)#ip http authentication local
CME-ZONE1(config)#no ip http secure-server
CME-ZONE1(config)#ip http path flash:/gui

Y habilitamos un usuarios con los privilegios para poder loguearnos desde el GUI

CME-ZONE1(config)#username cisco privilege 15 secret cisco

Paso 4: Configuramos las extensiones que serán asignadas a los teléfonos que se registren con el CME.

CME-ZONE1(config)#ephone-dn  1  dual-line
Habilitamos el modo de configuración del teléfono IP, con la opción dual-line permitimos que un mismo teléfono tenga la opción de manejar dos extensiones al mismo tiempo

CME-ZONE1(config-ephone-dn)#number 3332
Definimos el primero número de extensión 3332

CME-ZONE1(config-ephone-dn)#name 3332
Definimos el nombre de la extensión, la cual se utiliza para el caller ID

CME-ZONE1(config)#ephone-dn  2  dual-line
CME-ZONE1(config-ephone-dn)#number 3333
Definimos el segundo número de extensión 3332
CME-ZONE1(config-ephone-dn)#name 3333

Paso 5: Definir los teléfonos que se registraran con el CME y las extensiones que recién creamos, las cuales les serán asignadas

CME-ZONE1(config)#ephone 1
Entramos al modo de configuración para el primer teléfono

CME-ZONE1(config-ephone)#mac-address 0200.4C4F.4F50
Configuramos la dirección MAC del primer teléfono que se deberá asociar al CME

CME-ZONE1(config-ephone)#type CIPC
Indicamos que el teléfono que estamos utilizando es el Softphone de CISCO (Cisco IP Communicator)

CME-ZONE1(config-ephone)#button 1:1
Con la opción button definimos que la primer extensión que hemos creado será asignada al primer botón de línea del CIPC

CME-ZONE1(config)#ephone 2
Entramos al modo de configuración para el segundo teléfono

CME-ZONE1(config-ephone)#mac-address 0200.4C4F.4F51
Configuramos la dirección MAC del segundo teléfono que se deberá asociar al CME

CME-ZONE1(config-ephone)#type CIPC
Indicamos que el teléfono que estamos utilizando es el Softphone de CISCO (Cisco IP Communicator)

CME-ZONE1(config-ephone)#button 1:2
Con la opción button definimos que la segunda extensión que hemos creado será asignada al primer botón de línea del CIPC

About these ads

10 Respuestas a “Configuración de Cisco Call Manager Express en Routers Cisco

  1. Hola,

    Una pregunta: En el paso 3, cuando copias los firmware del teléfono a la memoria flash del router, imagino que los has descargado de la web de cisco. Lo único, ¿Cómo sabes cual es el directorio donde descomprimir el firmware? Estoy configurando unos equipos físicos con unos terminales 6911, y no se cómo dejar el nombre exacto.

    Un saludo y gracias!

    • Utilizas el comando Archive, eso lo haces directamente cuando estas enviando el archivo que contiene el CME, basicamente la función de este comando es crear todo el arbol de directorios dentro de la flash con la misma estructura que contiene el archivo .tar luego de eso tienes que crear el alias hacia los archivos de la versión de firmware que utiliza tu telefono. Si tienes alguna duda adicional con gusto lo vemos.

      Saludos.
      Eduardo Molina.

      • Hola Eduardo,

        Conseguí hacerlo funcionar con éxito, gracias a tus explicaciones. Lo único, yo no he tenido que cargar ningún fichero de firmware durante el proceso. El router que utilizo es un Cisco 1861, que trae CME ya integrado. Si los teléfonos traen su firmware por defecto, lo único que han necesitado es registrarse en la centralita.

        El próximo paso será comprobar que al conectar el PC en cascada, funcione correctamente bajo la VLAN, aunque esto son cosas de switching ya.

        De todos modos voy a investigar más sobre los firmware, ya que en muchos manuales encontrados por la red realizan este mismo paso.

        Un saludo!

      • Que bueno que hayas podido configurar el CME y que el material del blog te haya sido de ayuda, en proximas entradas voy a publicar algo de SRTS y redundancia.

        Saludos
        Eduardo Molina

  2. estimado, sabes como aplicar TLS y SRTP, yo segui un manual de buenas practicas de cisco, y no funciono, los telefonos no registran. Los certificados los levante en el mismo router. Te dejo la configuracion

    ctl-client
    server tftp 171.68.10.1 trustpoint tftp-server
    server cme 171.68.10.1 trustpoint cme-server
    server capf 171.68.10.1 trustpoint capf-server
    sast1 trustpoint sast1
    sast2 trustpoint sast2
    !
    capf-server
    port 3804
    auth-mode null-string
    cert-enroll-trustpoint IOS-ca password 1 14092011
    trustpoint-label capf-server
    source-addr 171.68.10.1
    !
    !
    !
    !
    !
    crypto pki server IOS-ca
    grant auto
    database url flash:
    !
    crypto pki trustpoint IOS-ca
    enrollment url http://171.68.10.1:80
    revocation-check crl
    rsakeypair IOS-ca
    !
    crypto pki trustpoint capf-server
    enrollment url http://171.68.10.1:80
    serial-number
    revocation-check none
    !
    crypto pki trustpoint cme-server
    enrollment url http://171.68.10.1:80
    serial-number
    revocation-check none
    !
    crypto pki trustpoint tftp-server
    enrollment url http://171.68.10.1:80
    serial-number
    revocation-check none
    !
    crypto pki trustpoint sast1
    enrollment url http://171.68.10.1:80
    serial-number
    revocation-check none
    !
    crypto pki trustpoint sast2
    enrollment url http://171.68.10.1:80
    serial-number
    revocation-check none
    !
    !
    crypto pki certificate chain IOS-ca
    certificate ca 01
    308201FB ….
    quit
    crypto pki certificate chain capf-server
    certificate 02
    308201C7 ….
    quit
    certificate ca 01
    308201FB ….
    quit
    crypto pki certificate chain cme-server
    certificate 03
    308201C7 ….
    quit
    certificate ca 01
    308201FB ….
    quit
    crypto pki certificate chain tftp-server
    certificate 04
    308201C7 ….
    quit
    certificate ca 01
    308201FB ….
    quit
    crypto pki certificate chain sast1
    certificate 05
    308201C7 ….
    quit
    certificate ca 01
    308201FB ….
    quit
    crypto pki certificate chain sast2
    certificate 06
    308201C7 ….
    quit
    certificate ca 01
    308201FB ….
    quit
    !
    !
    archive
    log config
    hidekeys
    !
    !
    interface Loopback0
    ip address 171.68.10.1 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 192.168.2.1 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    no ip address
    shutdown
    duplex auto
    speed auto
    !
    ip forward-protocol nd
    !
    ip http server
    ip http authentication local
    no ip http secure-server
    ip http path flash:
    !
    !
    control-plane
    !
    telephony-service
    max-ephones 10
    max-dn 10
    ip source-address 171.68.10.1 port 2000
    secure-signaling trustpoint cme-server
    cnf-file location flash:
    cnf-file perphone
    max-conferences 8 gain -6
    transfer-system full-consult
    tftp-server-credentials trustpoint tftp-server
    server-security-mode secure
    device-security-mode authenticated
    !
    !
    ephone-dn 1
    number 5050
    !
    !
    ephone-dn 2
    number 5051
    !
    !
    ephone-dn 3
    number 5052
    !
    !
    ephone-dn 4
    number 5053
    !
    !
    ephone 1
    no multicast-moh
    device-security-mode authenticated
    capf-auth-str 5050
    mac-address 0800.27B8.86A9
    type CIPC
    button 1:2
    !
    !
    !
    ephone 2
    no multicast-moh
    device-security-mode authenticated
    mac-address 0800.27AE.F9B7
    type CIPC
    button 1:1
    !
    !
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    login
    !
    ntp clock-period 17247042
    ntp server 171.68.10.1
    !
    end

    Router#show ephone registered

    Router#
    Router#show ctl-client
    CTL Client Information
    ———————-
    SAST 1 Certificate Trustpoint: sast1
    SAST 1 Certificate Trustpoint: sast2
    List of Trusted Servers in the CTL
    TFTP 171.68.10.1 tftp-server
    CME 171.68.10.1 cme-server
    CAPF 171.68.10.1 capf-server

    Router#
    Router#show capf-server summary
    CAPF Server Configuration Details
    Trustpoint for TLS With Phone: capf-server
    Trustpoint for CA operation: IOS-ca
    Source Address: 171.68.10.1
    Listening Port: 3804
    Phone Key Size: 1024
    Phone KeyGen Retries: 3
    Phone KeyGen Timeout: 30 minutes
    Device Authentication Mode: Null-String

    Router#show capf-server sessions
    Active CAPF Sessions
    Phone ID State

    • Como punto adicional, tienes que tomar en cuenta que tu estas configurando la seguridad con TLS y SRTP, por lo que la configuración del teléfono tiene que considerar el device-security-mode encrypted y tu estas utilizando el authenticated.

      Puedes habilitar el debug en el router para ver capturar los logs.

  3. Estimado el DHCP esta configurado! no lo comente antes, pero si saco de la configuracion del ephoned evice-security-mode authenticated y la dejo device-security-mode none, los telefono autentican sin problemas

  4. un saludo cordial desde cartagena Colombia les comentoque he tenido muchos problemas para montar esta plataforma en los router de la serie 2900 y registrar los teléfonos IP SPA303, he probado con otros teléfonos mas viejos de la serie 7975 y si me funciona, tambien con el softphone IP comunicator me fubnciona. si me pueden ayudar se los agradecería.

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s